The info for this watch decsribes it as being able to upload to a mac, and needing a firmware update to be done before that can happen. Has anyone worked out the steps to update the firmware using a mac? I have the download file but cant work out how to use it to update the watch


Hi Derryn,

The software for upgrading the firmware is still available for Windows only at this moment, so you have to the upgrade with a Windows machine.

  1. You have to download USB Driver, Updater_Installer and the Firmware V1.0G1206A
  2. install it on a Windows machine (tested on Windows 10 )
  3. make sure the watch is running in COM mode.
  4. Connect GW-60 to the computer, after that the watch must be visible in the Update_Installer software
  5. Select the firmware file and proceed with the upgrade as described 

After you upgrade the GW-60, make sure you switch it to Mass-Storage-Class (MSC) mode via the GW60 settings menu. Use the Mass-Storage-Class (MSC) mode for access from non-windows devices (for example Mac OSX), change it to this mode in the settings-menu at the watch before connecting it by USB, after that the downloads of session-data can be done via the Mass-Storage-Class (MSC) mode. When attached the right way to the Mac you have one additional USB device visibile in Finder, on this device you will find the session data in a file with the extension .sbp . We have tested all of this and it's works perfect. (macOS Sierra Version 10.12.1) . We will make a short how-to video in the next days...  

Software can be found at:

GW-60 USB Driver
GW-60 Util_Installer
GW-60 Updater_Installer
GW-60 Firmware V1.0G1206A
GW-60 QuickStartGuide_en

great, thanks very much for this info! much appreciated

Derryn Arthur

It's our pleasure :) With both Mac and Windows users in our team we know the feeling :)

Hi, would it be possible to give some tips on how to download the usb driver onto windows? Ive got the utility and updater installed ok, but the pc is not recognising the device (using windows 10).

I downloaded the usb driver file, and then clicked on the setup x64 file under the downloads folder, it gave a message saying it was successfully installed but is not recognising the GW60 when I plug it in (the device is powering up ok though)


thanks a lot


Hi Derryn,

Make sure the watch is set to COM mode when connecting to the Windows 10 machine , i'also did a reboot after installing the driver on Windows 10..... 

Hi GP35, yes in COM mode and rebooted

The watch is not showing in drivers at all, even though Im getting intstallation sucessful message 



I mean not showing in devices


When set to COM mode i don't think i should appear as 'device'  in  your Windows enviroment, COM mode means it will act like an USB COM Device (like the old serial COM port for modems etc etc) , siwtch to COM mode and the watch must be visibile in the UPDATE_INSTALLER Software.... When switched back to MSC mode after the firmware upgrade the watch will show up as an external USB drive (both in Windows and MAC OSX enviroments). Good luck !

The watch isnt visable in the UPDATE INSTALLER software either, Im getting a 'Port open failed' error message.

Which makes me think the watch isnt being recognised by the PC at all for some reason, as I cant access it in Utility either.

Will keep trying and if I can solve it put an update up here. It may even be my PC (HP Spectre) as there is some dialog on on gps product forums with similar issues.



Hi Derryn,

As promised we just created a small 'How to upgrade firmware..."  ....

Short video with detailed instructions how to upgrade your GW-60 GPS with the latest firmware from Locosys. After upgrading it can be connected as external USB device on both Mac and Windows machines

Hi thanks so much for posting the video, that is really helpful. I have hit my watch set up now, my cable was faulty and replacement coming. Tried it with someone else's cable and all working well. Great product and support by Locosys and yourselves. 

Thanjs again for your help and making this video



Hi Derryn,

Great to hear that everything solved now, we think Locosys has made a really cool product, all based on the continous effort of the worldwide GPS Speedsurfing Community both and GPS Teamchallenge. Really happy with the GW-60 , the quality and ease of use !

GP3S Crew

Just updated our product support pages for the GW-60, please check it out right here


I have no @500 in the session results I have posted trough the site. Can you take a look at this? Tnx!

Hi Patrick, can you forward your track to ? Thnx !

Tnx for solving this!

Min speed was set at 15km instead of 0km



does GW-60 store the sessions only in SBP format?
Meaning all sessions in 1 file?

Can't it save it also as SBN like GW-31? ( 1 file per session)


Can anyone confirm if this is a full replacement for the GT-31? Does it do everything the 31 does, is it as accurate? Actually is it faster?

Looks like a much handier way to record speeds.




Yes, this is the full replacement for the GT-31, please check out our GPS info pages here ->



In the current setup all session info is indeed stored in one file, we will discuss this with Locosys to enhance this if possible. 

would be great, many thanks
KR Peter

BETA Firmware

Locosys just released a BETA Firmware version including 5x10s AVG, @500, 100M, 250M and 500M ! We have tested this, if you want to try it , you can download it here ->



some question for Usage:

  1. In settings the item Logging: 1khz / 5khz / smart
    Which one would be the right?
  2. Logging starts after pressing "GPS" button.
    But did it end if i switch in Time Mode?
    Time Mode would be helpful for Races or one Hours.


Hi Werner,

  1. All settings can be found here,  logging advised to set to 5Hz
  2. Yes, logging is switched of when in Time Mode, good suggestion to improve this for Race Clock feature, 

Hi, I'm sure, i havent asked if i found the settings somewhere on gp3s website. It would be helpfull to have a link from "here" ;-)

Hi Werner, here again the right link (it's also above) ->


aaaahhhh thank you. I found the fotografs now :-O

Perfect :)

Also some "How to video's..." here ->

how we can see the Alpha 500 on the w60?
Can not see
Which programa I can also see the tracks.

Hi Andre,

You have to install the latest BETA firmware , 

BETA Firmware

Locosys just released a BETA Firmware version including 5x10s AVG, @500, 100M, 250M and 500M ! We have tested this, if you want to try it , you can download it here ->

For analyse you can you GPS Results or GPSAR Pro.

Hi GP3S Crew

1. I installled the new BETA firmware but no @500 on the display (it shows "0" and you can see the result only after downloading).

2. Not able to read the sbp file with GPSresults (I can to post it though and it apppears in the site). I can only read the NMEA file (but I can't post that one, of course). The sbp file shows the date of the session but there are too many trackpoints and hours of use in it.

Hi Minos,

Have you checked all settings are correct ? Also please mail your track to, so we can take a look....

All settings here ->

For GW-60 user under Mac,  Go to this website, they can map out the data in your watch.

It is fun to see your route

René B



Is it normal that during the charging of the battery, the display of GW-60 is lit all the time?


Is it possible to raise the alarm sound as it´s very weak even the batt is fully charged?


Why can´t I see top 10 speeds and top 10 AVG speeds anymore? Only what I can see is PVT and current speed. Before it showed top 10´s too.


Thanks and cheeers :-)



Is it normal that during the charging of the battery, the display of GW-60 is lit all the time?


Is it possible to raise the alarm sound as it´s very weak even the batt is fully charged?


Why can´t I see top 10 speeds and top 10 AVG speeds anymore? Only what I can see is PVT and current speed. Before it showed top 10´s too.


Thanks and cheeers :-)

I have now had 3 sessions with the new GW-60. Its super comfortable, easy and much nicer to view speeds on the water. However I am struggling with a few things.

- Reset sessions. Yesterday I thought I had reset the device for a new session, but when I checked the data it still had everything from the previous session. Do you need to reset both the speed data AND the distance before each session?

- Double Session. I can not see any way to have 2 sessions in 1 day. For example maybe the morning is slalom on 7.8. Then afternoon is speed on 6.3. The old GT31 you simple turned it off and back on again and it saved it as a new session. IS there anyway to do the same with the GW-60

- When I plug it into my MAC I get this message everytime, although I can download the data file and process it without problmes. macOS can’t repair the disk “LOCOSYS_MSC”. 

- Lastly is there anyway to set the file to name itself to the date? Again the GT31 was great for this and I coudl save all the files on my computer and they were easily sorted. The new device I have to first unlock the file, then rename it manually. 

Any advice most welcome. 

Also it woudl be useful to have some guidelines on the correct settings to have in the menu for best results. Instructions booklet is a bit lacking.

Otherwise everything is great with the watch.




I have just updated the firmware to V1.0G1206C but cannot seem to access the beta firmware, have i missed something?, GW60 working fine in every other aspect just not the results page!

Many thanks


the tracks uploaded from GW60 will not be displayed from dashboard with "more session Info">"show Track on map"

If you want a track to check take this:

Hi !

Any possibilities to have knots as speed indicator on GW60 ?

Regards, Lars N

Hi Werner,

This seems not GW-60 related, check tis one out ->

Could you provide info how you uploaded the track ?

GP3S Crew

Hi Lars,

This is already possible, go to the settings menu and change KM to NM (Nautical Miles) - >


Hi GP3S Crew,

problem seems to be solved with new Version of GPS Result.

Thank you


Thanks !

Hi GP3S Crew,


Ik kon mijn gw60 wel leeg maaken maar de aantal km bleven er opstaan.

Wat kan ik doen als dat nogmaal gebeurd ??

Is uploaden van de trackinfo vanuit de gw-60 via een usb (in mass storage mode) via een android of IOS smartphone / tablet direct naar mogelijk? Op vakantie/trips gaat mijn laptop normaliter niet mee. 

Anyone using GW60 on MacBookPro running OSX 10.8.5 ?
I cant get my GW to show up as device at all, despite doing the UMS and MSC class settings.
I see from another comment that someone had a faulty cable. I will try it on another mac somehere and see if it shows up.

In reply to previous message - it seems my cable is quite erractic, only someties charging and connecting.  Have it working now - at least I dont need a new computer :)


Latest firmware also can be found here ->

GREAT assistance from the GPS crew for my problems with my GW-60. Jan Hendrik was a big help to solve my problem. I did the BETA firmware update and my GW60 got stuck...just screen with light and nothing else happening. Then I waited the device to unload, but nothing happend when I connected to the computer. I send my GW60 to Jan Hendrick in Holland and he send me new one back!! Great service! Then Jan found out (I think we learned this now) that you can still install Firmware even if the device is not showing any numbers on it....but the firmware can be loaded anyway! No I have my device with the latest Firmware GW60_ARFW_V1.2A0314B...and it works great!! Thanks guys!

Thinking of replacing my gt31. 

am I right that it works on a mac but you can't load the latest firmware.

ok love the idea of the gps watch , but god its not as simple as the gt31 , ok after finally updating the fireware , i think although no 500 no 250 no 100 no avg 10s .......

i used it today for the first time to see how it works , love the 10s and the peaks etc , ok so now the problem starts , ive just connected it to the mac , watch is in ums mode and shows up on the mac , but when i download it comes up with no data ???? ive not deleted anything 

any ideas gps crew


cheers matty


Hi Matthew, you can forward you track to and we will take a look.... 

ok on way :)

Reading this forum, I can't keep from wondering if the GW-60 is already available as a commercial product (must be, as I am seeing several non-technical surfing buddies using it) or is it actually still in beta test and development ?

Hi Pat,

No worries, the GW-60 is full operational, and stable since the first introduction to the market. With the latest firmware a lot of new features where added on special request of the community, we think it's a good thing Locosys has chosesn this approach. It's very important to read the instructions and watch the how-to-vid's before you go on the water. Most of the issues mentioned above here are caused by human errors (as always :) ) . It's also good to share this information and feedback on this forum fully into the open, this way we can share all the info we have and learn from the experience from others.....

Hi GP3s crew,


Is it right that the latest firmware update can not be found at the Locosys website?

The latest firmware always can be found here ->

I feel like an idiot, but something went horribly wrong with my update.
I did exactly what GPSspeedsurfing says in the youtube videos.
Instead the GW-60 said: Update unsuccesfully

Since then, my watch has gone blanc and unable to connect with my laptop.

What should I do?


Hi Dennis,


Make sure you let the battery run flat for at least 24 hours....then do the procedure again.... 



Thank you for your quick response!
It worked and the new firmware is a lot better!

Again, Thank you!!!

hi guys

great job, the GW-60 works perfect for me, yesterday used the GT-31 and GW60, compared the results and they were nearly the same, differences were marginal. 

I never saw an answer on John Sky, i have the same problems, can't find the way to reset everything.   how can i rename the file? 




I cannot upload  a track again via the online upload  track  tab.

I sailed today, tried to upload the track and all the  autouploader shows is one of my sessions from February.

It seems I have constant problems trying to upload?

Any help would be great.

Hi Adam, please mail your track file to and we will take look....

We are sorry to inform you that a large quantity of GW-60's has been stolen from our office last weekend ! Besides the GW-60 devices also a lot of personal stuff has been stolen, so a great loss......

There is a chance someone involved in this crime will try to sell these devices within the windsurf-community. If anyone is trying to sell a GW-60 from a suspicious source, please contact us directly at , so we can inform the local police authority with this important information !!! All serial numbers of the stolen GW-60's have been registered, and will be blocked at, so in fact a stolen device will be almost useless...

Thank you all for your support on this, for customers who want the order the GW-60 there will be no issue, we already have additional stock available, so delivery can be done under normal conditions.

GP3S Crew

Dylan de Jong & Jan Hendrik de Bruin

Same issue as Patrick and John. How do I reset everything for a new session?

hi John and Martin,  i found it.  on watch modus, push on adjust then "Reset Disp", then ALL

then go to GPSstand, there also Adjust, go to yes, do the same in top result and AVG. 

everything should be reset after thes actions 

Hi i just bought the GW60 watch and i cannot download the software on my Mac, can someone help??





Its program was made for Windows only....maybe in the near future they will make it for Mac too. I had to use a Windows lap to update my GW-60 too :-(