My Mac Book Pro cant find my GW60 easily. It takes 0 to 50 minutes before GW60 pops on the Mac´s desktop. Anyways it begins to charge the GW60 instantly but on the Mac´s screen it comes whenever it likes. No, I didnt touch at all to GW60 nor the cable - just wait long enough and it will be connected. It remains connected for 1 to 10 minutes and then it disconnects itself but it will be back if you keep waiting... I dont know whats wrong...maybe its because of Mac, GW60, cable... I just know its €%€#€ annoying.


Thanks and cheers

I find that on my MacBook Pro with USB C, USB 3 hard drives were not mounting reliably at all. I connected a USB 2 hub to the USB C "dock" and it's still not perfect, but vastly better. I don't have a GW-60 yet (just ordered one), but if you have an old USB hub somewhere, you should give it a try.

like 10 seconds on my macbook pro 2013 , no problems ,with no usb hub .

I've had the same, since yesterday i do the following:

I first connect the usb cable to the mac usb port, GW60 in "USB CLASS UMS" mode, then select "TO USB MSC" on the GW60, then connect with the cable with the GW60 (GW60 lights up and is being charged), then push the adjust/enter button on the GW60 and it becomes visible in finder. 


Maybe you give this a try.

I haven't tried on my MacBook Pro yet (that one has USB C and connecting to hard drives has been spotty on it), but the GW-60 is working very reliably on my old iMac.

I made a quick bash shell alias to copy the file from the device to a folder on my Dropbox. Maybe some of you will find this useful (add this line to your .profile file, open a terminal window and use the gw60copy to copy the file - remember to edit the target path to your liking, as you probably don't keep you log files in the same path as I do):

alias gw60copy='cp /Volumes/LOCOSYS_MSC/GPSLOG.SBP ~/Dropbox/ipad/GPSLogs/`date -r /Volumes/LOCOSYS_MSC/GPSLOG.SBP "+%Y-%m-%d-%H%M.SBP"`'

I noticed that if I just use the Finder to copy the file, the copy is actually locked, which means it can't be renamed unless I unlock it first. The files copied with the above alias are not locked and they are named based on the modification date and time of the file, so you get a unique filename for each log automatically.