I have a few problems with my GT31 / firmware v1.4 B0315c

Problem 1:
My GT31 seems to miss some functionality in the 'Misc' menu for example: delete all and also the setting to activate 'looping' of 2s max/max run etc. in the my display.

Any suggestions?

Problem 2:
To solve problem 1, my solution would be new firmware. But even with Tom Chalko's manual: no succes.
Every time I execute the GT31 Update I get the message: Frimware update failed: exit code:1. I just can't seem to get the firmware on the GT31. Any help is appreciated.

Btw: In my windows7 control panel, the device is listed under COM5 and I've selected COM5. So that should be ok

Problem 3
With the NavilinkII software I can make a connection through COM5 with my GT31. I can read data, but I cannot write date. For example I tried to write Tom's default setting, but I get an error: Error[1]:ERROR_PORT

Hope someone can help me out



Problem 1 - solved by updating the firmware - see problem 2.

Problem 2 - I have never been able to get an update to work through win 7, or vista. It works fine with XP.

Problem 3 - Dont bother with navilink unless you are going hiking and planning to upload a route. Save your data on an SD card, and use a reader - for more info.

Hello Iwan,  just to clarify things.

Problem 1.  That should read looping of the 10s / Max speed run (ns / max set to ON)

Problem 2.I have done the update procedure many times now on both xp and win 7 (32bit o/s) without a problem. Just about to test the procedure on Win7 x64. 

Send me an email  oph @ hotmail dot co dot uk and I will send you my notes (and update files) that I used to talk our Ian Richards through the update procedure on his GT31s  (firmware v1.4  B0803T)  - essentially the notes are just an expanded form of Tom's procedure, in readiness for video (mp4) documenting the whole process from start to finish, including the internal switch setting for updating the GT31. 

Problem 3. I agree with Lea

best regards


Problems sovled!

Howard, thanks for your 'manual'.

The trick was: just put my USB cable in a different port indecision