Just bought a brand new GT31, but I'm having difficulties updating the firmware. I own a Mac, so I had to borrow the Windows laptop from my neighbour. He’d like it back soon, hope someone has advice.

I tried to follow the instructions on Tom Chalko's page, but
- My (new) GT31 did not come with an installation CD. Where can I get the required USB-serial driver?
- Select the COM port? Seriously? I don’t have a serial cable. Couldn’t plug it in the GT31 either if I had one. What’s up? The GT31 came with a USB cable…
- When I start up GT31updater, I cannot select a COM port. Nor USB for that matter.
- Updating the firmware looks promising at first (the red status bar slowly fills up), but ends rather disappointingly in an error.


The driver you need is for a built in chip that acts as a USB to serial convertor in the GT-31. So once it's installed you will just see a COM port that is used to transfer data to and from your GPS. Just plug in the USB cable that came with your GPS, that's all you need.

If you plug in the USB cable into the GT-31 and then the laptop, it should usually install a driver automatically. However, depending on the Windows version (and I have no experience with Windows 8 yet) it might not work out of the box. I do know though that the driver you're looking for is for the PL2303 from Prolific. Probably downloadable here:

Once you have that installed, reboot your PC, plug in the GPS again and try again following Tom Chalko's guide. Now you should actually be able to select a COM port.

Best of luck.

Super advice Oane, worked like a charme. Tom's instructions are perfectly clear, but without the required software impossible to follow. Plugging in the GT31 did prompt Windows to search for a driver, but it didn't find one by itself. Thanks!